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Technical Terms

Draw Instance All elemento elements that can be drawn 
can also be drawn multiple times at different 
places in the draw order. A draw instance is 
the same as a “draw order node”.

Draw Order The order of drawing figures or elements. 
The same as “display list” in other software. 
Stickman and Elemento supports hierarchy 
draw order which allows one element to be 
a sub node of another, or a figure drawn 
inside another figure.

Frame Time Line The time line in Stickman that shows key 
frames and a preview of it's value.

Key Frame The value of a figure property at a specific 
time. For example the positions of the 
control points.

Matrix Adapted from mathematics because 
Stickman & Elemento use matrices as the 
underlying structure to transform position, 
rotation, scaling and sharing of graphics.

A matrix is a node in Elemento to transform 
the drawing of sub nodes.

The matrix tool in Stickman is used to 
animate position rotation and scaling of the 
selected figure.

Secondary animation For example blinking eyes or minor 
movements that makes the animation look 
more natural. In Stickman you often start 
with the main movement and then add 
secondary animation.

A good trick is to use matrix tool first to 
move the figure and then control points.

Skeleton A figure can contain simulation elements 
like bones, rigids or ropes. All simulation 
elements together perform the skeleton of 
the figure.
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Slider Time Line The time line in Stickman that shows the 
time and a key frames as small colored 
rectangles.
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Stickman Manual

Menu Overview

File->New
Creates a new, empty scene. If there are any unsaved changes in the current scene, a 
dialog will ask you whether to save or not.

Shortcut: Ctrl+N or Alt, Enter, Enter

File->Open
Opens an existing scene from the local machine hard drive. If there are any unsaved 
changes in the current scene, a dialog will ask you whether to save or not.

Shortcut: Ctrl+O or Alt, Enter, O

File->Import->Add Picture
Adds a picture from the local hard drive to the scene. After selecting a file, a new window 
will appear where you can make some corrections to the picture before adding it. Two 
control points are added to the picture that can be used to move it with Control Points 
Tool.
Shortcut: Ins, 3 or Alt, Enter, I, Enter

Reset Picture Resets the picture to the original state.
Reset Control Points Moves the control points back to the default 

position. The default position is on the left 
and right side, between the top and the 
bottom.

Remove Backcolor The picture gets analyzed in groups and the 
color with largest group is assumed to be 
the background. All groups with same color 
as the background color is removed. This 
function is not anti aliased.

Smooth Adds a blur effect to the picture.
Paint Effect Adds a uniform color effect to the picture. 

You can use this to create cartoon 
backgrounds from real photos.
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File->Import->Add Deformed Picture
Adds a picture that can be deformed by controls points.
You can use the bone tool to add control points.

Shortcut: Ins, 4 or Alt, Enter, I, A, Enter

Reset Camera Tool Resets the camera tool to the default 
position.

Clear Control Points Removes all control points added with bone 
tool.

Make Transparent Detects the background from the image and 
removes it.

Blur Picture Adds a blur effect to the picture.
Reset Picture Resets the picture to the original state.

File->Import->Package Figure
Adds a figure from a figure package.

Shortcut: Ins, 1 or Alt, Enter, I, P or Alt, F, Enter, Enter

File->Import->Local Figure
Adds a figure from the local hard drive.

Shortcut: Ins, 2 or Alt, Enter, I, L or Alt, F, Enter, A, Enter

File->Export->Render Time Line
Renders the scene with the current camera from the first visible frame in slider time line to 
the last visible frame.

Shortcut: Alt, Enter, E, Enter

File->Export->Render From Beginning
Renders the scene with the current camera from frame 0 to the last visible frame in slider 
time line.

Shortcut: Alt, Enter, E, R, Enter

File->Export->Easy Rendering
Shows a dialog where the user can choose between presets for output resolution and 
format.
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Shortcut: Alt, Enter, E, E

Small Movie For small animations to post on YouTube , 
record to DV-tape or TV broadcasting.

Cinema For animations with widescreen resolution, 
for use on DVD, Cinema or HD TV 
Broadcasting.

Web Flash For web animations

File->Export->Advanced Rendering
Shows a dialog where the user can set a custom resolution, start and end frame and 
choose which camera to use.

Shortcut: Alt, Enter, E, A

File->Export->Sprite Sheet
Renders each frame to the same image that can be imported into a game engine for 
character animations. Useful for Windows, Java or Flash game engines. Exports to PNG 
that keeps the transparency information. If you want to create a separate mask, use a 
photo editor like GIMP or Photoshop.

Shortcut: Alt, Enter, E, S, Enter

File->Export->Single Frames
Renders each frame to a single image stored in PNG format to keep the transparency 
information. The frames are numbered from 00000 – 99999.

This function is useful to combine Stickman with other animation software like 3D Studio 
Max, Blender or Maya.

Shortcut: Alt, Enter, E, S, S, Enter

File->Save
Saves the scene. You need to type a file name if the scene is not already saved.

Shortcut: Ctrl+S or Alt, Enter, S

File->Save As
Saves the scene with another name. The user continues to work with the new file name. 
No changes are saves to the old scene.
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Shortcut: Alt, Enter, A

File->Exit
Closes Stickman. If there are any unsaved operations, a dialog will ask whether to save or 
not.

Shortcut: Alt+F4 or Alt, Enter, X

Edit->Undo
Goes back one step in history. The history will be cleared when saving.

Shortcut: Ctrl+Z or Alt, E, Enter

Edit->Redo
Goes forward one step in history. The forward history will be cleared when performing a 
new operation.

Shortcut: Ctrl+Y or Alt, E, R

Edit->Copy->Selected Control Points
Copies the position of the selected control points. The copied positions are not relative to 
any figure, so you can copy and paste positions between figures. 

To use this command, select Control Points Tool (F4) and drag a rectangle around the 
control points you want to select. Hold Shift and select more control points to add them to 
the selected group.

Shortcut: Ctrl+C, 1 or Alt, E, Enter, C, Enter, 1

Edit->Copy->Matrix
Copies the current matrix state of the selected figure. The copied matrix state is not 
relative to parent relations, so you can copy and paste matrices between figures.

To use this command, select Matrix Tool (F6).

Shortcut: Ctrl+C, 2 or Alt, E, C, Enter, 2

Edit->Paste->Selected Control Points
Pastes the copied control point positions. In some cases, the figure will not move exactly 
to the new positions if it is limited by it's skeleton.

Shortcut: Ctrl+V, 1 or Alt, E, P, 1
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Edit->Paste->Matrix
Pastes the copied matrix state to the selected figure.

To use this command, select Matrix Tool (F6).

Shortcut: Ctrl+V, 2 or Alt, E, P, 2

Edit->Insert->Package Figure
Adds a figure from a figure package.

Shortcut: Ins, 1 or Alt, Enter, I, P or Alt, F, Enter, Enter

Edit->Insert->Local Figure
Adds a figure from the local hard drive.

Shortcut: Ins, 2 or Alt, Enter, I, L or Alt, F, Enter, A, Enter

Edit->Insert->Picture
Adds a picture from the local hard drive to the scene. After selecting a file, a new window 
will appear where you can make some corrections to the picture before adding it. Two 
control points are added to the picture that can be used to move it with Control Points 
Tool.
Shortcut: Ins, 3 or Alt, Enter, I, Enter

Reset Picture Resets the picture to the original state.
Reset Control Points Moves the control points back to the default 

position. The default position is on the left 
and right side, between the top and the 
bottom.

Remove Backcolor The picture gets analyzed in groups and the 
color with largest group is assumed to be 
the background. All groups with same color 
as the background color is removed. This 
function is not anti aliased.

Smooth Adds a blur effect to the picture.
Paint Effect Adds a uniform color effect to the picture. 

You can use this to create cartoon 
backgrounds from real photos.
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Edit->Insert->Deformed Picture
Adds a picture that can be deformed by controls points.
You can use the bone tool to add control points.

Shortcut: Ins, 4 or Alt, Enter, I, A, Enter

Reset Camera Tool Resets the camera tool to the default 
position.

Clear Control Points Removes all control points added with bone 
tool.

Make Transparent Detects the background from the image and 
removes it.

Blur Picture Adds a blur effect to the picture.
Reset Picture Resets the picture the original state.

Edit->Insert->Camera
Adds a new camera. A color dialog appears to let the user set a color that identifies the 
camera. In Design Camera Tool you can see the camera views as colored rectangles. This 
is useful when dealing with more than one camera angle. The key frames of camera tool is 
also colored in the same color.

Shortcut: Ins, 5 or Alt, E, I, 5

Edit->Insert->Sound
Adds a new sound to the scene. Sound files are in WAV format (8 or 16 bit) and should be 
saved in the same directory as the scene. If you are sending the scene, by email, make 
sure you have included the sound files too. Stickman will automatically look for the sound 
files in the same directory as the scene file if it can't find the original file.

If Stickman does not understand the format you add, it will ask you whether to convert the 
file. After the convertion process is done you need to add the sound file ending with “wav” 
file extension. For example: “sample.au” is converted to “sample.au.wav”. The “sample.au” 
file is not overwritten.

You need to add a key frame with speaker tool to play the sound. Each key frame triggers 
playing the whole sound. For example you can create walk sounds by adding a key frame 
for each step.

Shortcut: Ins, 6 or Alt, E, I, 6
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Edit->Insert->Key Frame
Adds a new key frame at the selected frame. The current state of the selected figure is 
used in the key frame value. Note that a key frame only controls the specific part of the 
figure that is activated in the tool.

For example you can make a man walking and then add eye blinking as secondary 
animation. The final animation is decided by the combination of key frames you added.

Shortcut: Ins, 7 or Alt, E, I, 7 or Alt, L, Enter

Edit->Insert->Key Space
Adds a new key space at the selected frame. A key space is an empty frame. You use this 
command to add space between key frames. All key frames before the selected frame 
hold their position, while all key frames equal the selected frame or after moves 1 frame to 
the right.

It is less work to add a key space instead of dragging all the key frame, one by one. 
Nothing happens if you add a key space after the last key frame, because there are no key 
frames to the right of the selected frame.

Shortcut: Ins, 8 or Alt, E, I, 8 or Alt, A, I

Edit->Delete->Selected Figure
Deletes the selected figure. All key frames, parent relations, draw order changes 
connected to the figure will be deleted.

Note that if you want to reload the last changes in the elemento file, you can use Figure-
>Reload Figure. If you want to keep the animation but want to replace the figure with 
another, use Figure->Replace Figure. If the replaced figure is not build the same way, the 
animation can get affected.

You can undo any time by pressing Ctrl+Z.

Shortcut: Del, 1 or Alt, E, D, 1 or Alt, F, Enter, D

Edit->Delete->Selected Camera
Deletes the selected camera.

Shortcut: Del, 2 or Alt, E, D, 2

Edit->Delete->Selected Sound
Deletes the selected sound.
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Shortcut: Del, 3 or Alt, E, D, 3

Edit->Delete->Key Frame
Deleted the selected key frame. The animation use in-between when the key frame is 
deleted.

Shortcut: Del, 4 or Alt, E, D, 4 or Alt, L, D

Edit->Delete->Key Space
Deletes the selected key space. All key frames to the left of the selected frame will hold 
their position. All key frames to the right of the selected frame will move 1 frame left.

If you want to delete many key spaces, select the first of them and use Edit->Delete-
>Following Key Spaces.

Shortcut: Del, 5 or Alt, E, D, 5 or Alt, E, D

Edit->Delete->Following Key Spaces
Deletes the following key spaces. All key frames to the left of the selected frame will hold 
their position. All key frames to the right of the selected frame will move left so the next key 
frame equals the selected frame.

Shortcut: Del, 6 or Alt, E, D, 6

Edit->Goto Frame
Navigates directly to a frame entered in an input box.

Edit->Computer Lab Preferences
Opens a dialog for setting computer lab settings. This menu will only be visible for 
administrator users, so students without administrator privileges can't change the settings.

You can use this menu to change the user directory of Stickman, so the class can share 
figures easily by adding figures to the shared directory. The figures will be available 
directly in the dialog for adding figure from a figure package.

To set up your own figure package, just add them to a new folder in the user directory in 
the “packages” folder. The user directory is located in “My Documents\stickman” by 
default.

Shortcut: Alt, E, C, C, Enter

View->All Figures
Shows all figures in the work area. Turn this on when you want to see how the animation 

Page 15 of 50



Stickman & Elemento Manual

will look like when finished rendering.

Shortcut: Alt, V, Enter

View->Selected Figure
Shows only the selected figure. If you use the select tool all figures will be displayed 
anyway, so you can click to select them.

This feature is very useful when working with complex animations and heavy graphics, so 
you can focus on the movement of a single figure and speed up the user interface.

Shortcut: Alt, V, S

View->Mouse
Toggles showing the mouse commands in the lower right corner of work area. You can 
turn this on or off.

This is great for presentations so you don't need to tell the commands you do.

Shortcut: Alt, V, M

View->Draw Effects
Toggles draw effects on or off. If this is turned off the effects will be ignored.

Draw effects are effects created in Elemento using special elements that are not supported 
in flash rendering, only AVI. You can turn this off to speed up the user interface while 
animating.

Shortcut: Alt, V, D, Enter

View->Draw Reference Points
Draws points in the work area that can be used as measure reference when animating. 
The points are generated in a way so the user can see the camera motion effect when 
previewing the animation.

Shortcut: Alt, V, D, D, Enter

View->Preview: Animation
Plays the frame range from the given start of the animation to the end when previewing. If 
end is not defined, the last visible frame in the slider time line will be used as the end 
frame.

Use this setting if you want to preview the final result of the animation.
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Shortcut: Alt, V, P, Enter

View->Preview: Time Line
Plays the frame range from the first visible frame to the last visible frame in the slider time 
line.

Use this setting if you are working on a long animation and want to preview short intervals 
while animating.

Time Line->Add Key
Adds a key frame to the selected frame.

Shortcut: Ins, 7 or Alt, E, I, 7 or Alt, L, Enter

Time Line->Delete Key
Deleted the selected key frame. The animation use in-between when the key frame is 
deleted.

Shortcut: Del, 4 or Alt, E, D, 4 or Alt, L, D

Time Line->Next Key Frame
Jumps to the next key frame.

Shortcut: Alt, L, N

Figure->Add From Package
Adds a figure from a figure package.

Shortcut: Ins, 1 or Alt, Enter, I, P or Alt, F, Enter, Enter

Figure->Add From File
Adds a figure from the local hard drive.

Shortcut: Ins, 2 or Alt, Enter, I, L or Alt, F, Enter, A, Enter

Figure->Delete Selected Figure
Deletes the selected figure. All key frames, parent relations, draw order changes 
connected to the figure will be deleted.

Note that if you want to reload the last changes in the elemento file, you can use Figure-
>Reload Figure. If you want to keep the animation but want to replace the figure with 
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another, use Figure->Replace Figure. If the replaced figure is not build the same way, the 
animation can get affected.

You can undo any time by pressing Ctrl+Z.

Shortcut: Del, 1 or Alt, E, D, 1 or Alt, F, Enter, D

Figure->Edit Fonts And Colors
Opens a new dialog where the user can edit fonts and colors of the selected figure. All 
elements that has references to pen, brush, color, text or number element will update their 
references through changing.

This is useful for small color adjustments to see the result immediately. This is also a good 
way to change number settings in a figure.

Shortcut: Alt, F, Enter, E

Figure->Keyboard Control
Opens a new dialog where the user can set keyboard specified poses. A pose means the 
current position of all control points in the control point tool. Each keyboard key from A-Z 
can be linked to a pose. You can add keyboard control to all levels. To change level use 
the hierarchy on the left side.

Shortcut: Alt, F, Enter, K

Figure->Reload Figure
Reloads the selected figure from the source. If you added it from the online library, 
Stickman will attempt to reload it from there. If you added the figure from a elemento file at 
the local machine, Stickman will try to reload it from that file.

Use this function if you want to reset the colors in the figure to their default value or you 
want to get the last figure changes.

Shortcut: Alt, F, Enter, R, Enter

Figure->Replace Figure
Replaces the selected figure with another elemento file stored on the local machine. A new 
dialog will appear that asks the user to select the elemento file of the new figure.

If you have created an animation that you want to redesign the figure a bit, you can 
download the figure from “Online Library” at 

http://www.cutoutpro.com/packages.html
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and modify it with Elemento and then use the replace figure function.

Shortcut: Alt, F, Enter, R, R, Enter

Figure->Figure Mixer
Creates new figures by the figures added to the scene. You can switch body, head and 
skin color to create new figures. At least two figures with correct head standard must be 
added to the scene.

Correct head standard in order to work with figure mixer:

neckPoint or headPoint The lowest control point of head.
topPoint The topmost control point of head.
headMatrix
|- head

A matrix called “head” that is attached to the 
neckPoint and topPoint.

To support skin color, link all Brush properties to a brush element named “skinBrush”.

Animation->Lock Selected Points
Locks the selected control points. Control points that are locked can not be selected or 
affected by simulation.

Shortcut: Alt, A, Enter

Animation->Unlock Points
Unlocks the locked control points. All control points that are locked will get unlocked.

Use this function if you no longer want to lock the control points.

Shortcut: Alt, A, U

Animation->Insert Key Space
Adds a new key space at the selected frame. A key space is an empty frame. You use this 
command to add space between key frames. All key frames before the selected frame 
hold their position, while all key frames equal the selected frame or after moves 1 frame to 
the right.

It is less work to add a key space instead of dragging all the key frame, one by one. 
Nothing happens if you add a key space after the last key frame, because there are no key 
frames to the right of the selected frame.

Shortcut: Ins, 8 or Alt, E, I, 8 or Alt, A, I
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Animation->Delete Key Space
Deletes the selected key space. All key frames to the left of the selected frame will hold 
their position. All key frames to the right of the selected frame will move 1 frame left.

If you want to delete many key spaces, select the first of them and use Edit->Delete-
>Following Key Spaces.

Shortcut: Del, 5 or Alt, E, D, 5 or Alt, E, D

Animation->Flip Horizontal
Flips the selected figure horizontally. You need to have matrix tool (F6) activated to flip.

Flipping is a good trick to use to turn an old background into a new one.

Shortcut: Alt, A, F, Enter

Animation->Flip Vertical
Flips the selected figure up side down. You need to have matrix tool (F6) activated to flip it.

Shortcut: Alt, A, F, F, Enter

Animation->Reset Matrix Tool
Resets the matrix tool to the default settings.

Shortcut: Alt, A, R

Animation->Walk
Opens a new dialog where you can generate walk cycles. The settings of the dialog will be 
remembered each time you open it but not saved when you close and reopen Stickman.

Note you should adjust the depth control points so the correct leg and arm is the front 
most. This can be checked easily by dragging the legs and arms of the figure so they 
overlap in control points tool. For example: When walking in right direction, the figure's 
right arm should be the front most, and the left arm behind the body.

Shortcut: Alt, A, W

Start The start frame to begin the walking. This 
will be the selected frame by default.

End The frame to stop walking. Each time you 
open the walk dialog Stickman will 
remember the difference between end and 
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start, using this formula:
end = start + last frame difference

Frame step The number of frame steps between each 
generated key frame. For example a value 
of 1 will make the figure walk (or run) very 
fast. A value of 10 will make the figure walk 
in slow motion.

Lift How much the legs will be lifted. A high 
value will make the figure running. A low 
value will make the figure sliding.

Knee Bend How much the knees will be bended 
forward.

Leg Swing How much the swing the legs forward and 
backward. A high value will make the figure 
take very large steps.

Move Arms Check this if you want to move the arms 
when walking. Uncheck this if the figure is 
carrying something and therefore should not 
move the arms.

Arm Bend How much the arms will be bended. A high 
value will make the hands closer to the 
body. A low value will make the figure move 
the arms straight.

Arm Lean How much to balance the arms forward or 
backward while walking. A high value will 
make the figure move the arms mostly 
forward. A low value will make the figure 
move the arms mostly backward.

You can change the body balance with 
control points tool before generating walk.

Inverse Direction Check this if you want the figure to walk the 
opposite direction. Make sure the order of 
the body parts are correct before generating 
walk cycles.

Follow Path If you already have a path that you want to 
walk along, use the matrix tool to animate 
the figure and then generate the walk 
animation with this setting checked. Put in 
enough time between the matrix key frames 
or the figure will stretch the legs too much.
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Generate Generates the walk cycle using the current 
settings.

Reset Default Settings Resets the walk options to the default 
values.

Camera->Goto Selected Figure
Navigates the current camera so the selected figure is in the center of the work area. If 
camera tool is selected, the selected camera will be navigated.

Shortcut: Alt, C, Enter

Camera->Reset Camera Tool
Resets the current camera to the default settings.

Shortcut: Alt, C, R

Packages->Import Package
Imports a new figure package from a file. The figure package will be imported into the user 
directory and then the package file will be deleted. This helps the user from cluttering up 
the desktop.

Note that you can also import a figure package file by just double-click it.

Shortcut: Alt, P, Enter

Packages->(Online Library)
Sets the default figure package in the “Add Figure” dialog to online library. This is not 
recommended because it is much slower than the offline library.

You can use this function if you want to check out the last figures in the offline library 
before downloading it.

Shortcut: Alt, P, Shift+8

Packages->Offline Library

Sets the default figure package in the “Add Figure” dialog to the offline library.

Shortcut: Alt, P, O
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Packages->”Others”
Sets the default figure package in the “Add Figure” dialog. The selected package will be 
displayed first when adding a new figure.

Tools->Design Camera Tool
Activates the design camera tool. The design camera tool is used to navigate the view of 
the work area. You can move, rotate or zoom the design camera.

Shortcut: F1 or Alt, T, Enter

Tools->Select Tool
Activates the select tool. The select tool is used to change the selected figure by simply 
clicking on it. You see the preview of the selected figure in the upper left corner of the work 
area. The selected figure will also be shown in the list of figures (category “Figures”).

You can also quick-select a figure by holding Alt down and select the figure. If you have a 
mouse with three buttons you can middle-click to select a figure. 

To the left of the select tool icon on the tool bar there is a small arrow. Click this to get a 
pop up list and change the selected figure.

Shortcut: F2 or Alt, T, S, Enter

Tools->Color Tool
Activates the color tool. The color tool is used to change colors in the animation by 
selecting a color pencil and then clicking on the area to change the color. You can right-
click to pick a color. Click on the preview color circle to get a dialog with more colors or 
change the alpha value (transparency).

The color tool updates all elements linked to the same brush.

Shortcut: F3 or Alt, T, C, Enter

Tools->Control Points
Activates the control points tool. The control points tool is used to animate body parts or 
custom animation with in-between support.

You can lock and unlock control points if you want them to stay constrained to the same 
position. See “Animation->Lock Selected Points”.

Some figures have custom tools that are displayed only in control points tool. This 
graphics is put inside a “design” element that is only visible in control points tool.
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On the left side you can change the control point level.

Shortcut: F4 or Alt, T, C, C, Enter

Tools->Switch Tool
Activates the switch tool. The switch tool is used to animate layers. For example a turning 
head. All figures have a “visibility” switch.

Click left mouse button to increment the switch. Click right mouse button to decrement the 
switch. Shift+Click to reset the switch to 0.

Shortcut: F5 or Alt, T, S, Enter

Tools->Matrix Tool
Activates the matrix tool. The matrix tool is used to animate movement, rotation, zooming 
and flipping at the same time. In-betweens are calculated automatically.

Move with matrix tool by dragging left mouse button.
Use right mouse button to rotate.
Hold Shift+click or press both mouse buttons to zoom.
Drag one side of the matrix grid to the other side to flip.

Shortcut: F6 or Alt, T, M

Tools->Path Tool
Activates the path tool. The path tool shows the path of the matrix center through the 
visible frame range of the slider time line. Normally you should first use the matrix tool to 
add key frames and then use the path tool to adjust the key frames.

The key frames are shown as white dots along the path. Use the left mouse button to drag 
them. If you want to add a key frame, double-click the selected frame in the slider time 
line.

The path goes from blue to red. The current frame is green. Blue is the beginning of the 
slider time line. Red is the end of the slider time line.

Shortcut: F7 or Alt, T, P

Tools->Camera Tool
Activates the camera tool. The camera tool works the same way as design camera tool. 
The camera tool sets key frames for an animated camera. All scenes have one animated 
camera by default, named “cam”. You can add unlimited number of cameras. Each 
camera got a color that helps identifying it.
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To create a new camera, click “Add” on the left side of the work area. Select a camera 
color and click “OK”. When you add a key frame it will have the same color as the camera 
color. When using the other tools you can see the camera view as a colored rectangle.

Shortcut: F8 or Alt, T, C, C, C, Enter

Tools->Speaker Tool
Activates the speaker tool. The speaker tool is used to trigger sounds. Each key frame 
tells Stickman to start playing the selected sound.

Remember to add a key frame with speaker tool when you add a new sound. Or else you 
will not hear anything!

Shortcut: F9 or Alt, T, S, S, S, Enter

Tools->Volume Tool
Activates the volume tool. The volume tool controls the volume and pan of the selected 
sound track.

You can use this tool to play a car sound that moves from left speaker to the right speaker. 

Shortcut: F10 or Alt, T, V 

Tools->Options
Opens a dialog for setting frames per second and resolution. These settings will be stored 
in the scene file.

Stickman is resolution independent animation software, which means that the work area 
has a predefined size no matter what the resolution of the rendered movie will be. The 
gray area shows the part of the picture that will be clipped away when rendering. This 
allows you to reuse your animation in many resolutions for different purposes, such as 
cinema and web.

Help->Help
Opens the tutorial web page at the home site of Cutout Pro. This is the main source for 
help to use Stickman and Elemento.

Shortcut: F11 or Alt, H, Enter

Help->Cutout Pro Website
Opens the home site of Cutout Pro.

Shortcut: F12 or Alt, H, C
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Help->About Stickman
Shows a dialog about Stickman.

Shortcut: Alt, H, A
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Tool Bar

New (Ctrl+N)
Creates a new, empty scene. If there are any unsaved changes in the current scene, a 
dialog will ask you whether to save or not.

Shortcut: Ctrl+N or Alt, Enter, Enter

Open (Ctrl+O)
Opens an existing scene from the local machine hard drive. If there are any unsaved 
changes in the current scene, a dialog will ask you whether to save or not.

Shortcut: Ctrl+O or Alt, Enter, O

Save (Ctrl+S)
Saves the scene. You need to type a file name if the scene is not already saved.

Shortcut: Ctrl+S or Alt, Enter, S

Undo (Ctrl+Z)
Goes back one step in history. The history will be cleared when saving.

Shortcut: Ctrl+Z or Alt, E, Enter

Redo (Ctrl+Y)
Goes forward one step in history. The forward history will be cleared when performing a 
new operation.

Shortcut: Ctrl+Y or Alt, E, R

Design Camera Tool (F1)
Activates the design camera tool. The design camera tool is used to navigate the view of 
the work area. You can move, rotate or zoom the design camera.

Shortcut: F1 or Alt, T, Enter

Select Tool (F2)
Activates the select tool. The select tool is used to change the selected figure by simply 
clicking on it. You see the preview of the selected figure in the upper left corner of the work 
area. The selected figure will also be shown in the list of figures (category “Figures”).
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You can also quick-select a figure by holding Alt down and select the figure. If you have a 
mouse with three buttons you can middle-click to select a figure. 

To the left of the select tool icon on the toolbar there is a small arrow. Click this to get a 
pop up list and change the selected figure.

Shortcut: F2 or Alt, T, S, Enter

Color Tool (F3)
Activates the color tool. The color tool is used to change colors in the animation by 
selecting a color pencil and then clicking on the area to change the color. You can right-
click to pick a color. Click on the preview color circle to get a dialog with more colors or 
change the alpha value (transparency).

The color tool updates all elements linked to the same brush.

Shortcut: F3 or Alt, T, C, Enter

Control Points (F4)
Activates the control points tool. The control points tool is used to animate body parts or 
custom animation with in-between support.

You can lock and unlock control points if you want them to stay constrained to the same 
position. See “Animation->Lock Selected Points”.

Some figures have custom tools that are displayed only in control points tool. This 
graphics is put inside a “design” element that is only visible in control points tool.

On the left side you can change the control point level.

Shortcut: F4 or Alt, T, C, C, Enter

Switch Tool (F5)
Activates the switch tool. The switch tool is used to animate layers. For example a turning 
head. All figures have a “visibility” switch.

Click left mouse button to increment the switch. Click right mouse button to decrement the 
switch. Shift+Click to reset the switch to 0.

Shortcut: F5 or Alt, T, S, Enter

Matrix Tool (F6)
Activates the matrix tool. The matrix tool is used to animate movement, rotation, zooming 
and flipping at the same time. In-betweens are created automatically.
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Move with matrix tool by dragging left mouse button.
Use right mouse button to rotate.
Hold Shift+click or press both mouse buttons to zoom.
Drag one side of the matrix grid to the other side to flip.

Shortcut: F6 or Alt, T, M

Path Tool (F7)
Activates the path tool. The path tool shows the path of the matrix center through the 
visible frame range of the slider time line. Normally you should first use the matrix tool to 
add key frames and then use the path tool to adjust the key frames.

The key frames are shown as white dots along the path. Use the left mouse button to drag 
them. If you want to add a key frame, double-click the selected frame in the slider time 
line.

The path goes from blue to red. The current frame is green. Blue is the beginning of the 
slider time line. Red is the end of the slider time line.

Shortcut: F7 or Alt, T, P

Camera Tool (F8)
Activates the camera tool. The camera tool works the same way as design camera tool. 
The camera tool sets key frames for an animated camera. All scenes have one animated 
camera by default, named “cam”. You can add unlimited number of cameras. Each 
camera got a color that helps identifying it.

To create a new camera, click “Add” on the left side of the work area. Select a camera 
color and click “OK”. When you add a key frame it will have the same color as the camera 
color. When using the other tools you can see the camera view as a colored rectangle.

Shortcut: F8 or Alt, T, C, C, C, Enter

Speaker Tool (F9)
Activates the speaker tool. The speaker tool is used to trigger sounds. Each key frame 
tells Stickman to start playing the selected sound.

Remember to add a key frame with speaker tool when you add a new sound. Or else you 
will not hear anything!

Shortcut: F9 or Alt, T, S, S, S, Enter
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Volume Tool (F10)
Activates the volume tool. The volume tool controls the volume and pan of the selected 
sound track.

You can use this tool to play a car sound that moves from left speaker to the right speaker. 

Shortcut: F10 or Alt, T, V 

Help (F11)
Opens the tutorial web page at the home site of Cutout Pro. This is the main source for 
help to use Stickman and Elemento.

Shortcut: F11 or Alt, H, Enter

Cutout Pro Website (F12)
Opens the home site of Cutout Pro.

Shortcut: F12 or Alt, H, C

Page 30 of 50



Stickman & Elemento Manual

Categories

Figures

Shows a list of figures added to the scene. The selected figure will always be selected in 
this list.

Add Adds a new figure from a figure package. 
The new figure gets selected automatically.

[...] Adds a new figure from the local hard drive. 
The new figure gets selected automatically.

Delete Deletes the selected figure.
Edit Fonts and Colors Opens a new dialog where the user can edit 

fonts and colors of the selected figure.

See “Figure->Edit Fonts and Colors” for 
more information.

Reload Figure Reloads the selected figure from the 
source.

See “Figure->Reload Figure” for more 
information.

Add Picture Adds a picture as a figure.

See “File->Import->Add Picture” for more 
information.

Animation

Control Points Activates the control points tool.

See 
“Tools->Control Points Tool”
“Animation->Lock Selected Points”
“Animation->Unlock Points”
“Animation->Walk”
for more information.

Switch Tool Activates the switch tool.
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See
“Tools->Switch Tool”
“Animation->Insert Key Space”
“Animation->Delete Key Space”
for more information.

Matrix Tool Activates the matrix tool.

See
“Tools->Matrix Tool”
“Animation->Flip Horizontal”
“Animation->Flip Vertical”
“Animation->Reset Matrix Tool”
for more information.

Path Tool Activates the path tool.

See
“Tools->Path Tool”
for more information.

Draw Order
In Stickman, draw order can be animated independently of parent relations. The start draw 
order is at the beginning of the animation, at frame -1. The user can animate the draw 
order using commands as “before”, “after” and “inside”. The draw order executes from the 
top to the bottom of the lists.

Start Draw Order

Shows the draw order at the beginning of the animation, at frame -1.
You can select multiple items by holding Shift or Ctrl. 

Move Forward (+) Moves the selected items forward.
Move First (++) Moves the selected items first.
Move Backward (-) Moves the selected items backward.
Move Last (--) Moves the selected items last.

Current Draw Order

Shows the current draw order at the selected frame. You can either animate the draw 
order by using the +, - buttons or use the “Change” button. The +, - buttons moves the 
selected item forward or backward one step at the time. The “Change” button puts the item 
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directly before, after or inside another figure.

Notice a small triangle appears in the slider time line after performing an animated draw 
order change. This indicates a draw order change for the selected figure.

The draw order animation is based on “Before”, “After” and “Inside” action. This allows you 
to add new figures later without disturbing the existing animation. These actions can't be 
moved because they are automatically removed when they are not necessary. This helps 
you from cluttering up the scene with many animated draw order changes.

Often it's good to do some planning before animating draw order. There can only be one 
draw order change per figure per frame. For example “car” before “background” means 
“car” is moving before “background”. Adding a new draw order change for “car” at the 
same frame will delete the previous action.

You can add “car” before “background” and “orange” before “background” without 
problems because they are two different figures that moves before the background. If you 
used “background” after “car” you can not use “background” after “orange”. Normally you 
don't need to think about this because the system is designed the same way as we think. If 
you stay to common sense you will have no problems. There are a few exceptions, for 
example when a figure rides a horse, the figure has each leg on each side of the horse. To 
solve this use “horse” inside “figure\body middle”.

A very special case is when more than one person is riding the same horse. This problem 
can only be solved by using tag elements in the figure elemento files. The horse needs a 
tagFilter element that draws the figures behind the horse, and then only the part inside a 
tag “frontLeg” before the horse. For more information see the Elemento documentation.

Move Forward (+) Moves the selected item forward. 
Move Backward (-) Moves the selected item backward. 
Change Puts a figure directly before, after or inside 

another figure.

Containers
All figures can have a relation. That means the matrix position, rotation and zooming is 
affected by another figure. For example, when a figure A has a relation to the left hand of 
figure B, the figure A is affected when the left hand of figure B moves. Figure A is the child 
and figure B is the parent. This is also called “parent hierarchy”. 

The relations can not be established if there are no containers in the parent figure. A 
“container” is simply an empty matrix node (see Elemento documentation) that is not 
inside another matrix node. Stickman interprets this as “we can put something into it”. The 
use of containers are split in two parts: Draw Order and Relations. A container can be 
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used to draw something inside it or connect a relation to it.

Start Relation

The relation at the beginning of the animation, at frame -1. When adding a start relation 
you tell Stickman to put the selected figure inside a container of another figure. The draw 
order remains the same, but when you move the parent figure all child figures that is 
connected to one of the containers will follow.

Animated Relation

It would be no point of using relations if they couldn't be animated. When you change the 
selected frame in slider time line, the active relation will be shown here. To create a 
temporary relation, select the frame and then the “/” button. If you want to destroy the 
connection between the parent figure and the child figure, use the “X” button. Note that the 
changes applies to the current frame and show up as small triangles in the slider time line.

Sometimes it's difficult to decide which frame to establish a relation and when to destroy it. 
Normally it's the same frame as when the two figures makes physical contact or loose 
physical contact. Stickman adds automatically two key frames to the matrix tool each time 
the animated relation is changed. The key frames prevents the figure from “jumping” inside 
another container. If you move the parent figure after creating a relation the two key 
frames will no longer be synchronized and “jumping” will appear.

Camera
Design Camera

Activates the Design Camera Tool. For more information see “Tools->Design Camera 
Tool”.

Camera Tool

Activates the Camera Tool. For more information see “Tools->Camera Tool”.

Sound
Speaker Tool

Activates the Speaker Tool. For more information see “Tools->Speaker Tool”.

Volume Tool

Activates the Volume Tool. For more information see “Tools->Volume Tool”.
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Export and Time Line
Animation Limits

Specifies the frame range of the animation. “Start” is the frame to start playing animation 
and “End” is the last frame to play. When you check “End” the current frame will be set as 
the end frame.

The start and end frame will be used as default settings when rendering in “Advanced 
Rendering” and “Easy Rendering”.

Output Format

Selects the preferred format to use in “Easy Rendering”. When you select “Small Movie” 
the default resolution will be set to 400x300. When selecting “Cinema” the default 
resolution will be set to 640x360. As this happens you can see the gray region in the work 
area change.

In the section “Convert AVI to” you can check the formats you want to publish the movie. 
The converted movie will use the same name as the rendered avi file but with an extra 
extension at the end. For example “basket.avi” is compressed to “basket.avi.mov” when 
MOV is selected. You can continue using Stickman meanwhile converting the AVI file.

MP4 A format that contains video and sound with 
very good compression, compressed with 
MPEG-4 standard.

MOV A movie that can be played with QuickTime.
MPEG Video file compressed with MPEG file.
FLV Flash Video file. Can be played from Flash 

applications. Often compressed with H.264 
standard.

ASF A movie that can be played with Windows 
MediaPlayer.

M4V A movie compressed with MPEG-4 
standard. Often used in podcasts.

VCD A movie compressed with MPEG-1 
standard that can be put on CD disks and 
played on DVD players.

VOB Movie format compressed with MPEG-2 
standard that can be played on DVD disks.

SWF Flash animation format. Contains the FLV 
data. The difference between rendering to 
flash with Stickman and converting AVI to 
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SWF is that the a converted AVI contains 
video data while Stickman Flash rendering 
renders vector graphics. Vector graphics 
takes less space than video and has better 
quality.

Time Line

“Offset” sets the frame to start the slider time line. You can change this when working with 
large animations.

“Length” is the number of frames in the slider time line. The minimum is 300 and maximum 
is 700.
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Buttons

Preview
Previews the animation in a loop. 

If View->Preview: Animation is checked the last frame will be either the end frame or, if not 
set, the last visible frame in slider time line.

If View->Preview: Time Line is checked, only the visible frames in slider time line will be 
shown.

Shortcut: Space

Rendering
Render Time Line

Exports the visible frames in slider time line.

For more information see File->Export->Render Time Line.

Render From Beginning

Exports from frame 0 to the last visible frame in slider time line.

For more information see File->Export->Render From Beginning.

Advanced Rendering

Shows a dialog where the user can set a custom resolution, start and end frame and 
choose which camera to use.

Shortcut: Alt, Enter, E, A

Easy Rendering

Shows a dialog where the user can choose between presets for output resolution and 
format.

For more information see File->Export->Easy Rendering.

Animation
Delete Key
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Deleted the selected key frame. The animation use in-between when the key frame is 
deleted.

Shortcut: Del, 4 or Alt, E, D, 4 or Alt, L, D

Add Key
Adds a key frame to the selected frame.

Shortcut: Ins, 7 or Alt, E, I, 7 or Alt, L, Enter

Next Key Frame

Adds a key frame to the selected frame.

Shortcut: Ins, 7 or Alt, E, I, 7 or Alt, L, Enter
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Elemento Manual

Menu Overview

File->New
Creates a new empty figure. If there are any unsaved changes a dialog will appear asking 
you to save.

Shortcut: Ctrl+N or Alt, Enter, Enter

File->Open
Opens a figure from file.

Shortcut: Ctrl+O or Alt, Enter, O

File->Import->Photoshop Layers
Imports PSD files as images. Layers with effects or vector graphics are not supported.

Shortcut: Alt, Enter, I, Enter

File->Save
Saves the changes.

Shortcut: Ctrl+S or Alt, Enter, S

File->Save As
Saves the figure to a new file. The user continues to work with the new file name. No 
changes are saves to the old figure.

Shortcut: Alt, Enter, A

File->File Info
Shows the figure backward compability and the relations between Stickman and Elemento 
versions.

Shortcut: Alt, Enter, F

File->Exit
Exits the program.
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Shortcut: Alt+F4 or Alt, Enter, X

Edit->Undo
Undoes the last operation.

Shortcut: Ctrl+Z or Alt, E, Enter

Edit->Redo
Redoes the last undone operation.

Shortcut: Ctrl+Y or Alt, E, R

Edit->Delete Unused Variables
Deletes variables that are not connected to any visible elements by references, 
expressions or simulation elements.

Shortcut: Alt, E, D

Edit->Optimize Drawing
Removes all draw instances of clip nodes that got only 1 sub node and do not have an 
expression for the Region property. The sub node is put at the same spot as the clip node.

Removes duplicate draw instances that follow each other.

Removes empty matrix nodes that does not work as containers.

Shortcut: Alt, E, O

Edit->Create Skeleton And Attach Graphics
Control points tool or bone tool may be selected to do this action.
This function creates skeletons and attach graphics to it automatically by analyzing which 
control points are over the graphics layer.
For example, if you have created a matrix node “head”, the function will detect all control 
points that are over “head”. If two control points are found, a bone is created and “head” is 
attached to the control points. If more than two control points are found, a rigid is created 
and “head” is attached to the two control points with longest distance to each other.
Before doing this action, make sure:

● The graphics are placed inside matrix nodes.
● That no bones are already created with bone tool.
● The control points are placed over the body parts so they can be detected.

Shortcut: Alt, E, C, Enter
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Edit->Clean Matrix Nodes
Transforms matrix nodes so they got the scaling factor Point(1;1) without disturbing the 
character rig.
By resizing the matrix nodes all non-absolute borders will have the same width for same 
values.
Shortcut: Alt, E, C, C, Enter

View->Show Reference
If checked, the reference figure or picture will be visible.

Shortcut: Alt, V, Enter

View->Reference
Selects an elemento file or picture that will be displayed in the background.

If you want to set the center of the figure to the center of the reference figure, you can use 
the placement tool (F6).

Shortcut: Alt, V, R

View->Draw Effects
Toggles draw effects on or off. If this is turned off the effects will be ignored.

Draw effects are effects created in Elemento using special elements that are not supported 
in flash rendering, only AVI. You can turn this off to speed up the user interface while 
animating.

Shortcut: Alt, V, D, Enter

View->Draw Reference Points
Draws points in the work area that can be used as measure reference. The points are 
generated in a way so you see the camera motion when using the camera tool. This 
feature is useful when you don't have a background to measure the camera movement.

Shortcut: Alt, V, D, D, Enter

View->Draw Transparent Background
Draws a check board background instead of white color which makes it easier to see 
which part of the figure that is transparent.

Shortcut: Alt, V, D, D, D, Enter
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View->Object Browser
Displays a list of all elements, actions and expression functions.
For example, search for “matrix” to get all expression functions and elements containing 
the word “matrix”.
Shortcut: Alt, V, O

Debug->Run
Starts evaluating the expressions of the figure. No references are active at run time. Use 
the same command to stop running. No changes done in run time modus will be saved. 
When entering design time modus the figure will reset to the state before entering run time 
modus.

In Elemento, the “Time()” function returns the seconds since entered the run modus.

Shortcut: Alt, D, Enter

Tools->Selection
Edits the selected draw element under “Draw Order”.

Shortcut: F1

Tools->Control Points
Shows the control points tool.

Shortcut: F2

Tools->Bones
Shows the bone tool.

Shortcut: F3

Tools->Switches
Shows the switch tool.

Shortcut: F4

Tools->Camera
Shows the camera tool.

Shortcut: F5
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Tools->Placement
Shows the placement tool.

Shortcut: F6

Tools->Reset Camera Tool
Resets the camera tool.

Shortcut: Alt, T, R, Enter

Tools->Reset Placement Tool
Resets the placement tool.

Shortcut: Alt, T, R, R, Enter

Tools->Keyboard Control
Opens a new dialog where the user can set keyboard specified poses. A pose means the 
current position of all control points in the control point tool. Each keyboard key from A-Z 
can be linked to a pose. You can add keyboard control to all levels. To change level use 
the hierarchy on the left side.

Shortcut: Alt, T, K

Tools->Draw
Creates a new draw instance of the selected variable and adds it to the end of “Draw 
Order”. You can also use the “Draw” action under “Actions”.

Shortcut: Alt, T, D, Enter

Tools->Rename
Gives the selected variable a new name.

Shortcut: Ctrl+R or Alt, T, R, R, R, Enter

Tools->Duplicate
Creates a copy of the selected variable.

Shortcut: Ctrl+D or Alt, T, D, D, Enter

Tools->Delete
Deletes the selected variable.
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Shortcut: Del or Alt, T, D, D, D, Enter

Help->Help
Opens up the tutorials web page at the Cutout Pro home site.

Shortcut: F11 or Alt, H, Enter

Help->Cutout Pro Website
Opens up the Cutout Pro home site.

Shortcut: F12 or Alt, H, C

Help->About Elemento
Shows a dialog about Elemento.

Shortcut: Alt, H, A
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Understanding Draw Order

Each visible element that have duplicates.

For example:

Draw Order
matrix1
|- ellipse1
matrix2
|- ellipse1
matrix3
|- ellipse1

will draw the same ellipse 3 times but transformed by 3 different matrices.

To create a duplicate use the “&” button.

Elemento automatically transforms draw elements when you move them.

For example:

When curve1 is put inside matrix1 the Points property of curve1 will change so the curve 
looks to seems to have the same shape.

To turn of automatic transform, turn off the “T” check box.
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Expression Programming

The true power of Elemento lays in the expression language, which gives you the 
possibility to program the behavior of graphics.

For example:
ellipse2.X = “Time()*20”
will move the X value of ellipse2 20 pixels per second.

An expression is optimized and evaluated only when necessary. For example when an 
arm of a figure is moved, only the expressions connected to the control points will be 
updated.

Each property on a variable can have an expression. When an expression refer to a 
property of other variables Elemento will calculate those expressions as well.

Recursive expressions are not allowed:
curve1.Points = “curve2.Points”
curve2.Points = “curve1.Points”
is not allowed because curve1.Points refers to curve2.Points and curve2.Points refers to 
curve1.Points, which after all does not make sense.

An expression can refer to its own element properties:
point3.Pos = “Closest(line1;.Pos)”
is allowed because “.Pos” refers to the value of point3.Pos and not the expression.
This expression is used to lock a control point to move along a line. Each time point3.Pos 
change Elemento will calculate the closest position on line1 and assign the value to 
point3.Pos.

Elemento use “,” as comma separator, since “.” is used to refer to a property like 
“ellipse5.Rectangle”.

Example:
rect1.X = “10,4” will succeed while
rect1.X = “10.4” will fail.

To see a complete list with functions goto View->Object Browser in Elemento.
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Working With Clip and Regions

A clip node draws only the parts of the graphic put inside it inside a region. If there is an 
effect element inside a clip node, the effect will only be applied to the region.

A region can be intersected, excluded or merged with other regions. Mostly you create a 
region from another shape as curve or polygon. The region cannot be saved and can only 
be generated by using expressions.

Infinite regions are allowed and often used to draw everything except a specific area. The 
region property of clip elements are infinite by default.

A clip node got an action “Hide Intersection” that can be used to hide parts of a border that 
intersects with another shape.

Region(variable) Creates region defined by shape.
Example: Region(ellipse2)

Region() or InfiniteRegion() Creates an infinite region.
Transform(region;matrix1;matrix2;...) Returns a transformed region from outside 

of matrix1 to inside the last matrix.
InvTransform(region;matrix1;matrix2;...) Returns a transformed region from inside 

the matrix1 to outside the last matrix.
Exclude(region1;region2;...) Excludes region2 and the following regions 

from region1.
Intersect(region1;region2) Intersects region1 with region2.
Union(region1;region2;...) Returns the union of the regions.
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Simulation and Attaching Graphics to Points
Simulation adds realism to the figure movements.
Simulation types:

bone Used to hold a constant distance between 
two control points.

feedback Used to limit rotation on a body part like the 
feet.

The easy way to use this is to convert a 
bone to feedback with the action “Convert to 
Feedback”.

rigid Holds constant relation between multiple 
points. Used in most figure bodies that got 
more than two control points.

rope Used on many control points to simulate a 
tail or rope.

The sum of simulation nodes on a figure is called a “skeleton”. A skeleton is not visible, 
therefore you need to attach the graphics to it. This is done by using the “Attach” action of 
a matrix. The “Attach” action creates a new matrix and puts the first matrix inside it. The 
new matrix got expressions so it moves with the control points at run time.
If you got a curve element that is the head of your figure:

1. Use the “Put in Matrix” action to put the curve inside a new matrix node.
2. Rename the matrix node to “head”.
3. Use the bone tool (F3) to create two control points for the head, one for the neck 

and one for the forehead.
4. Rename the control points to “neckPoint” and “topPoint” respectively.
5. Use the bone tool (F3) to create a bone between the control points.
6. Rename the bone to “headBone”.
7. Select “head” (F1) and use the “Attach” action to attach it to “headBone”.
8. If you have done everything correct, the “head” will be put inside a new matrix 

“headMatrix”.
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Morphing and Deforming

Morphing is the technique to transform one shape into another shape. This is done at run-
time using expressions.

Deforming is the technique to control a shape by some sort of control elements.

You can also use the deform node, which draws all sub nodes deformed.

If you want to create the effect of a 3D object rotating using a curve, you can flip a copy 
either horizontal or vertical and revert the points. Then use a Morph expression to morph a 
third copy.

Avg(point1;points2;...) Returns the average point collection of 
arguments. The point collections need to 
have the same number of points.

Blend(originalPoints;points1;blend1;points2;
blend2;...)

Blends point collections relative to the 
original points. Equals shape blending in 
most 3D programs.

This can be used to create face 
expressions.

Cluster(points;currentPos;originalPos;startIn
dex;endIndex;strong)

Returns a point collection that is affected by 
a control points at the indexes from 
startIndex to endIndex. Strong is a factor of 
how much to affect the points by inverse 
distance from the control point. Usually 
between 0,9-1.

Can be used to create eyelids.
Cluster(points;currentPos;originalPos;startIn
dex;endIndex;strong;direction)

Same as the previous except that you can 
give the direction -1 to affect all points 
except the points between startIndex and 
endIndex.

Cluster(points;currentMatrix;originalMatrix;st
artIndex;endIndex)

Inverse transforms the points from 
startIndex to endIndex through 
originalMatrix and then transforms them into 
currentMatrix.

Can be used to control move, scale and 
rotation with a matrix as control structure.

ClusterMix(originalPoints;points1;points;2...) Mixes all points that are different from the 
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original points. All points that are mixed 
should be different from the original points 
all the time or they will “jump”.

Can be used to mix result from Cluster 
functions.

CurveControl(points;controlPoints;originalC
ontrolPoints;controlDistance)

Affects the points using a control shape. 
Use Deform instead if you need rotation.

Can be used to make small dynamic moves 
to a more detailed shape using a simple 
shape.

Deform(points;basePoints;controlPoints) Deforms the points using a collection of 
points as control structure.

LinearFade(startValue;endValue;value;start
Points;endPoints)

Linear fade between startPoints and 
endPoints.

Morph(time;points1;points2;...) Morphs between the point collections using 
time as a factor from 0 (the first points) to 1 
(the last points). If you want to morph in 
cycle you can use this syntax:

Morph(Time()
%1;curve1.Points;curve2.Points;...;cu
rve1.Points)

Spiral(points;angle;length) Bends the points in a spiral assuming the 
straight shape is along the x-axis.

Can be used to create a tail or trunk.
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